COMPUTER-7

1. Number System

A. Multiple Choice Questions :
1. (a), 2. (), 3. (c), 4. (a), 5. (a).

B. Fill in the blanks by choosing the correct words from the
brackets :
1.8,2.12,3.11,4.0t09,5. 1.

C. Write ‘T’ for true or ‘F’ for false statements :
1.T,2.T,3.F,4.F, 5. F.

D. Write down the binary number for the given decimal

numbers :
Decimal number Binary number
2 10
3 11
S5 101
6 110
Decimal number Binary number
7 111
8 1000
9 1001
10 1010
E. Give the base values of the following number systems :
Number Systems Base Value
Decimal Number System 10
Binary Number System 2
Octal Number System 8
Hexadecimal Number System 16

F. Short Answer Type Questions :

1. A number system is a system to represent or express the
numbers of certain type. There are four types of number
systems.

2. 1 represents ON and O represents OFF.



3. Different types of number system are : binary number system,
decimal number system, octal number system and hexadecimal
number system.

4. 0-7 are represented by Octal Number System.

. Long Answer Type Questions :

1. To convert from octal to binary, follow these steps :
(i) Firstly, convert from octal to decimal.
(ii) Now, convert from decimal to binary.
2. (E5) 1 —> (M),
It involves two steps :
Step 1 : Convert from Hexadecimal to Decimal
=(Ex16") + (5% 16°)
=(14x16)+(5x1)
=224+ 5=(229),
Step 2 : Convert from Decimal to Binary
2 229
114
57
28
14
7
3
1
0

Result is :
(E5);¢ =(11100101),
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3. (74)g —> (M),
To convert from octal to binary involves two steps :
Step 1 : Firstly, convert from Octal to Decimal.
=(7x8")+(4x8"
=56 +4=(60),
Step 2 : Convert from Decimal to Binary

2 60
2 35 0
2 15 0 Resultis:
£ 7 1 (74)g = (111100),
2 3 1
2 1 1
0 1



4. Write down the correct output on the basis of Binary Arithmetic

operations :
Operation Output
0+1 1
1-1 0
1*0 0
1+1 11
0*1 0
141 11
0-1 10

A. Conversion
1. Binary to Decimal

(1011), = ()50 (100101), = ()1 (100001), = ()10
1011 100101 100001
E1x23:1x1:1 g1x2§’=1x1=1 @1x2?—1x1—1
1x2l=1x2=2 ox2'=0 ox2'=0
0x22=0x4=0 1x2°=1x4=4 1x2°=0
1x2°=1x8=8 ox22=0 ox22=0
= 1+2+0+8 ox2*=0 ox2'=0
-1 1x2°=32 1x2° =32
(1011), = (11)4, = 144432 =37 = 1432 =133
(100101), = (37); (100001), = (33);,
2. Decimal to Binary
(712)1 = (), (7710 = (), (1325)15 = (?),
2] 712 2| 77 21325
20356 | 0 2] 38] 1 2] 662] 1
2178 o 2] 19] 0 2] 331 o
2] 89 o 2 91 2] 165] 1
2] 441 2 41 2| 821
2] 220 0 2 200 2| 41| o
2] 11| 0 2 1o 2] 20] 1
2] 5]1 01 2] 10| o
2] 21 2] 5] o
2 1o 2] 21
0 2] 1] o
(712)0 = (1011001000), || (77);9 = (1001101), 0] 1
(1325) 5 = (10100101101),
3. Octal to Decimal
(1024)g = ()19 (130)g = (M1 (512)g = (M1
102L . 130 512
4x8°=4
L>2x81=16 L>0x80=0 L>2x8°=2x1:2
0x8 =0 3x8' =24 1x8'=1x8=38
1x8% =512 1x8* =64 5 x 82 = 5%64 =320
= 4+16+0+512 = 0+24+64 = 2484320
=532 =88 =330
(1024)g = (532)19 (130)g = (88)1 (512)g = (330




4. Hexadecimal to Decimal

(45)16 = (M0
45

(1BF) 16 = (D10 (77016 = D10
1BF 77C

|::5><16°=5><1 =5 |_'-:F><160=15><1=15 |_'-:C><160=12><1 =12
4x16'=4x16 = 64 Bx16'=11x16 = 176 7x16'=7x16 = 112

— 5164 1x16%=1%256=256 7x16%=7x256= 1792
=69 =15+176+256 =12+112+1792
(45)16 = (69)19 =447 =1916

(1BF) 6 = (447)19 (77C)16 = (1916);,

5. Binary Addition

101110
+ 110010
1100000

(101110), + (110010), | {(10000001), + (100000001),|| (1100), = (101),

10000001 1100
+ 100000001 + 101
110000010 10001

6. Binary Subtraction

(1001), - (1001), | | (110010), - (101100), | | (10101011), - (110100),)
1001 110010 10101011
- 1001 -101100 —110100
0000 000110 01110111

7. Binary Multiplication
(11100), x (11), | |(101010), x (111),| | (11001100), x (1100),

11100 101010 11001100
x 11 x 111 x 1100
11100 101010 11001100
11100X 101010% 11001100%
1010100 101010% % 11001100% X
100100110 11001100xx X
100110010000

8. Binary Division

10
10
0

(1010), + (10), | | (1110100), + (110), | | (100010011), + (101),
10)1010(101 | |110)1110100( 10011 ||101)100010011 (110101
10 110 -101
1001 110
-110 -101
0110 110
110 -101
0 101
-101
_0




Using Excel as Database

Multiple Choice Questions :

1. (a), 2. (b), 3. (a), 4. (¢), 5. (a).

Fill in the blanks by choosing the correct word from the

brackets :

1. Insert, 2. Filter, 3. Field, 4. Ctrl + C, 5. Paste.

Write ‘T’ for true or ‘F’ for false statements :

1.F,2.F,8.F,4.T,5.T.

. Fill in the blanks with correct options :

1. Data, 2. Tables, 3. View, 4. Data Tools, 5. Data.

Short Answer Type Questions :

1. Database is the collection of information in an organised
manner.

2. Field : Field is a column which contains only one type of data.
For example : In the given figure, Name is the field which
contains only names of the students.

Field Name : Field name is the name given to the headings of
columns like name, Swimming, Cricket, Football etc.

3. Record : A record is a row that has the entire information

about a person or organization.

. Freeze Panes are used to freeze a particular row or columns.

. No, we cannot freeze the top row.

. When we enter the data in the form of table in the Excel sheet,
we enter the data for each row one by one. This way, we manage
the lists where information is arranged in the rows of the table.
MS Excel 2016 provides a special feature of Form, which offers a
simple way to deal with big data arranged in rows.

7. Sort option is used to arrange data in selected cells.

8. Filtering the data means to retrieve only those records which
satisfy the given criteria. If one does not want to get the entire
details of the organisation, he/she can filter out the details and
get the required records.

9. Two rules that should be followed before Advanced Filter :

(i) Header row must have a unique column heading.
(ii) You cannot have any blank row in data set.

10. A PivotTable is a modern tool in Excel 2016. It helpful to

summarize and analyze the data.
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F. Long Answer Type Questions :

1. 1. Firstly, create a table in Excel.



9.
10.
11.
12.

13.

.We have to convert column names into a table. Select

Table Headings. Now, click Insert > Table.

. A Create Table dialog box opens.
.Make sure that the My table has headers checkbox is

marked. Click OK button.

. The column names are converted into table.
.Now, to add form, go to File> Options. An Excel

Options dialog box opens.

. Now click on Ribbon.
. Click on Choose commands from drop-down list box

and select Commands Not in the Ribbon.

Click on Form option.

Click on New Tab. Under New Tab, select New Group.
Click Add button.

You will see that a form has been added to the
New tab, in the Ribbon.
Click OK button.

2. (a) Adding a new record :

1. Select field names of a table, click on New Tab>
Form.

2. A Sheet 1 dialog box opens.

3. Now add values of your choice in each field. That way, a
record will be created.

4. Click on New button. A new record will be created
and added to the table in Excel.

5. You can move to previous or next record by clicking on
the Find Prev or Find Next buttons accordingly.

6. Click on Close button to close the data form.

(b) Searching a record :

1. Click on New Tab> Form.
2. From the Sheet 1 dialog box, click on Criteria button.

3. Now type the data in a field whose record is bought by
you. You can type the name in the field Emp name.
Press Enter.

(c) Deleting a record :

1. Click on New Tab> Form.

2. A Sheet 1 dialog box opens.

3. Click on Find Prev or Find Next to find the record
you want to delete from the table.

4. As and when you arrive at the record that was being
bought by you, click on Delete.



5. A message box appears to confirm the deletion of a
record.
6. Click OK button.
(d) Arranging data :

1. Click on the drop-down arrow of the field name
according to which you want to arrange the data.
(Example : Salary)

2. From the drop-down list, select the required option.
(Example : Largest to Smallest)

3. Thus, the data will be rearranged in the table.

. Select the table which you want to sort.

. Click on Data tab.

. Select the Sort option under Sort & Filter group.

. A Sort dialog box opens.

. Under the option column, click on sort in the drop-down
list. You have to select column A in Sort.

. Click on Sort on drop-down list, select Cell values.

. Click on Order drop-down list, select A to Z.

. Click OK button.

. The data in the table will be arranges according to Column.

. Select the table from which you want to retrieve the data.

.Go to Data tab and select Filter option under Sort &
Filter group.

. Small arrows will be added in all the field names.

. Now click on the arrow next to Bill Amount field name.

. Click on the Select All check box to uncheck it.

. Now select the checkboxes of 575 and 500.

7. Click OK button.

It will filter the list and display only those records that satisfy the
criteria i.e. only those records will be displayed whose bill
amount is 575 and 500, as shown in the figure.
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i Cust_Name .1} Cust_ID Bl Location Bl Payment Mode Bl Bill Amount EJ

3 | Ashok Kumar 10031 New Delhi Cash 575
15 |Zeenat 10069 Gurgaon Online 500,
16
17
18

5. Advanced filters are used to apply complex criteria to create a
list of unique items or to extract specific items to different
locations or to filter data in multiple fields.



Two rules that should be followed before Advanced Filter :
(i) Header row must have a unique column heading.

(ii) You cannot have any blank row in data set.

Let us see how it works :

1. Now, you can add more than two blank rows above the
range. These rows will be used for criterion. Right click on
the row and select Insert>Entire Row option.

2. Select the column headings say A6:E12. Copy the range by
pressing Ctrl + C.

3. Click on cell A3 and paste the copied contents by pressing

Ctrl + V.
. Type the criteria under the column heading. For example :
type >500 under bill amount heading.
. Type Gurgaon under Location.
. Select the data set.
. Go to Data>Sort & Filter>Advanced option.
. An Advanced Filter dialog box will pop up on the screen.
9. Click on Copy to another location radio button.
10. List range will contain the selected range of data set.
11. Specify the Criteria range.
12. Specify the destination range in the Copy to option where
the filtered rows will be copied. (say $A$21:$E$21)
13. Click on the checkbox of Unique Records only to extract
the unique records.
14. Now Click on OK.
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2
3 Gurgaon 1000
.
5 |Ashok Kumar 10031 New Delhi Cash 575
5 | Balwinder Singh 10034 Gurgaon Online 1020
7 | Danish 10045 Jalandhar Cash 1250
8 Disha 10040 Ghaziabad Online 3000
9 | Ekamjot Singh 10042 Patiala Online 2500
10 Meenakshi 10033 Panipat Cash 1700
11 |Navita 10023 Jalandhar Cash 1560
12 |Sunita 10050 Karnal Online 3500
13 Tanya 10047 Ludhiana Online 4100
14 | Taranjit Kaur 10062 Gurgaon Online 2100
15 |Urvashi 10041 New Delhi Online 2800
16 Vani 10051 New Delhi Online 2200
17 |Zeenat 10069 Gurgaon Online 500,
18
LY Cust_Name Cust_ID  Location Payment Mode  Bill Amount
20 Balwinder Singh 10034 Gurgaon Online 1020
21 Taraniit Kaur 10062 Gurgaon Online 2100

) = | Sheets Sheetd Sheet? Sheetd Sheetd Sheet10 Sheet1l Sheet12 | Sheat2

6. You can enter all types of data in an Excel worksheet. However,
you can allow only a particular data to be entered in a cell. In



that case, other types of data cannot be added to that cell. This
can be done by using Data Validation feature of MS Excel 2016.
It allows you to do the following :
m Make a list of the entries that restricts the values allowed in a
cell.
= Create a prompt message explaining the kind of data allowed
in a cell.
= Create messages that appear when incorrect data has been
entered.
= Set a range of numeric values that can be entered in a cell.
Lets see how it works :
1. Select the range of cells E7:E12.
2. Go to Data tab>Data Tools group>Data Validation
option.
3. A Data Validation dialog box opens.
. Now, go to the Settings tab. Set the criteria for validation
by clicking the drop-down arrow of option Allow.
. Click on any value from the list (say Whole Number).
. Click on the drop-down arrow of the Data option.
. Select any option (say less than).
. In the Maximum text box, type 500.
. Click on the Input Message tab. In Title, type Validation.
In Message, type Enter a whole number less than 500.
10. Click on Error Alert tab. In the Error Message, type Invalid
input.
11. Now, Click on OK.
12.If you enter the data which does not match the Data
validation criteria, an error message will be displayed.
. Subtotal is another feature provided by Excel 2016 which is
used to summarize the different groups of data and create an
outline for your worksheets.
Subtotal is used to calculate the sum of a set of numbers. This
sum is then added to another calculated sum of set of numbers
to get the grand total. Besides, it also helps you group and
summarize data. For this purpose, you can use functions such as
MAX, MIN, AVERAGE, SUM, etc. An outline is created, with the
help of which you can show or hide the details for each subtotal
or view just a summary of the subtotals and grand totals. Let us
see how it works :
1. Create a table in a worksheet.
2. Select any cell in the data set.
3. Go to Data tab>Outline group>Subtotal option.
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4.

7.

A Subtotal dialog box opens. Here, you need to specify

three things,

= In At each change in box, select the column
containing the data you want to group by. (say Area)

= In Use function list box, select the function you want
to apply to calculate the value. (say Sum)

= In Add Subtotal to list box, select the checkbox of the
column you want to subtotal. (say Sales)

. Now, click on Replace current subtotals. This option

will be deselected. It will also overwrite the existing
subtotal, if it existed.

. You will see that the Summary below data check box is

marked by default. Let it be marked because after
calculation, it will place the total below the corresponding
column.

Click OK button.

8. Steps to create a PivotTable are :

1

6.

[oe]

10.

11.

12.

13.

. Create a table of Employee in Excel 2016.
2. Select the entire table.

3. Go to Insert>Tables group>PivotTable option.

4.

5. Now select a table or range. The radio button is selected by

A Create PivotTable dialog box opens.

default.

Table/Range box contains the range that you have
selected.

. In Choose where you want the PivotTable report to

be placed, New Worksheet radio button is selected by
default.

. Click OK button.
.A new worksheet will be opened with the layout of

PivotTable. You can also see the PivotTable Fields task
pane on the right side of the window.

Now select the fields that are to be added.

For example : Select the check boxes of Emp id and
Salary.

In Values, select the Sum of Salary and drag it to the Rows
section.

Now to change the heading from Rows labels to Emp id,
first deselect the Defer Layout Update checkbox which is
marked by default to uncheck it.

Now select the cell Rows labels. In this cell, type Emp id.
And your pivot table is ready.



General Activity

A. Find out any five new features in MS Excel 2016 which
were not a part of previous versions and write down
below :

1. ‘Tell Me’ Box, 2. Forecasting, 3. Search Field, 4. Data Grouping,
5. Histograms.
a

3. More About MS Excel 2016

A. Multiple Choice Questions :
1. (a), 2. (0), 3. (a), 4. (c), 5. (a).

B. Fill in the blanks by choosing the correct word from the
brackets :
1. Column, 2. Bubble, 3. Combo chart, 4. Data, 5. Insert.

C. Write ‘T’ for true or ‘F’ for false statements :
1.F,2.T,3.F,4.T,5. T.

D. Match each chart type to its related image :
1. (d) Column Chart
2. (c¢) Bubble Chart
3. (a) Area Chart
4. (b) Pie Chart
E. Look at the following chart and name the various
elements present in it :

Comobdnied Test Meport

ladddddd’
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1. Chart Title, 2. Chart Area, 3. X-axis, 4. Y-axis, 5. Axis Title, 6. Data
Labels, 7. Data Table, 8. Gridlines, 9. Legend, 10. Trendline.



F. Short Answer Type Questions :

1. A chart is the pictorial representation of data in the form of a

graph.

2. (a) Column Chart : In column charts, vertical bars are used
to compare data values. Bars are tall rectangular rods which
are displayed in vertical side. In column charts, categories
are typically organised along horizontal axis and values
along vertical axis. It is the default chart of MS Excel.

(b) Bar Chart : Bar chart is used to display the data in the
form of horizontal bars. This horizontal bar is the tall
rectangular rod which is displayed in horizontal direction.
In this type of chart, categories are represented in
horizontal axis. All of the bar charts are available in 2D and
3D formats. Just like column chart, it also has bars in the
form of cylinder, cone and pyramid type.

(c) Pie Chart : It is a form of a circle or pie (in case of a 3D
image). The slices of the pie represent percentages. It shows
the contribution of each value to the sum of items. It is best
to use this type of chart when you have only one data series.

(d) Line Chart : Line chart is used to display trends over time.
The data is displayed in the form of lines. It has lines going
across the chart horizontally, with the values axis on the left
side of the chart. It works similar to a plotter which plots the
graph on a graph paper using pens which draw the lines in
X-axis and Y-axis direction.

(e) Doughnut Chart : This type of chart is called Doughnut
because it is shaped like a doughnut, a circle with a hole in
it. As in the pie chart, it displays data as sections of a circle,
but may have multiple data series. Each data series that you
plot in a doughnut chart adds a ring to the chart. After you
create a doughnut chart, you can rotate the slices for
different perspectives, focus on special slices by pulling out
slices of the doughnut chart, or change the hole size of the
doughnut chart to enlarge or reduce the size of the slices.
Two formats of doughnut charts are : Doughnut and
Exploded Doughnut.

(f) Scatter Chart : Scatter chart is also known as XY chart.
This type of chart is used to compare pairs of values. Its
purpose is to observe how the values of two series compare
over time or another category. X axis is usually assigned to
an independent variable, whose value is controlled or set by
the experimenter. The Y variable then becomes the
dependent variable i.e. the values that follow from each

value of X.



(g) Area Chart : These charts are similar to line charts.
However, the area below the plot line in such a chart is
solid. It shows trends over time or another category. It
emphasises on the magnitude i.e. volume of change over
time. Area chart comes in two formats : 2D Area chart and
3D Area chart. In many cases, 2D version of the Area chart
can be ineffective in displaying multiple series of data
meaningfully. So, we can make use of 3D version of area
chart.

3. Legend : It contains symbols, patterns and colour assigned to
data series.

4. Plot area is the area where the objects and elements of a chart
are plotted.

Whereas, Chart area is the area where a chart is present. This

area has all objects and elements of the chart.

5. MS Excel 2016 supports three types of sparklines :
(i) Line : This type represents data values with or without any
marker for every data point.

(i) Column : The column type of sparkline represents the data
values in the form of tiny columns.

(iii) Win/Loss : The Win/Loss type of sparkline is a binary
chart which represents data values as Win or Loss, where
win blocks are represented by blue squares and little high
than Loss blocks which are represented by red squares.

. Long Answer Type Questions :
1. To create a chart, we need to follow the given steps.
1. Data has been shown here. Create an Excel sheet using this
data.
. Select the data including Field names.
. Go to Insert menu.
.In Charts group, click on the drop-down arrow next to
Column Chart.
. Click on the drop down next to the Column Chart in
Charts group.
. Select the Cluster Column Chart from 2-D Column.
. The chart will be created on the basis of your selection. You
can see it in the worksheet beside your selected portion.
8. When you select the chart you have created, a Chart Tools
tab appears on the ribbon.
9. Click on Chart Tools. Various tools related to the selected
chart will be displayed.
10. To add various chart elements in the chart, click on the
drop-down arrow next to Add Chart Element, and add
any element (discussed in previous topic).
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11. Click on the Quick Layout drop-down arrow and select
the layout to change the layout of the chart from the
available options.

12. There is another way to change chart colours. Click on
Change Colour, it is a drop down button. From the
window that pops up, select a colour of your choice.

13. Chart Styles consists of various styles available for the
chart, choose one by clicking on it.

14.You can also swap the data by moving it from X-axis to
Y-axis and from Y-axis to X-axis. For this, there is one option
available in Chart Tools i.e. Switch Row/Column.

15. Select Data option is used to change the data range for the
chart. You click on this option; a Select Data Source
dialog box opens. Enter the new data range and click OK
button.

16. Chart Type option is used to change the type of chart to
any other chart like Pie chart, Area Chart, Line Chart,
Scatter chart etc. You just need to click on Chart Type and
a dialog box opens. Select the chart of your choice and your
existing chart will be replaced with the new chart.

17. Move Chart option is used to move the chart to another
worksheet in the same workbook or another workbook.

2. (a) Chart Title To give a title to the chart :

1. You have created a chart. Click on it.

2. Go to Design tab.

3. Click on the drop-down arrow of the Add Chart
Element option.

4. From the list, select the Chart Title option.

5. A further list opens. Click on None if you don’t want to
display the chart title.
Otherwise, click on Above Chart or Centered
Overlay option.

6. A Chart Title textbox opens.

7. Type the title in it and click outside the chart.

(b) Axis

1. Select the chart.

2. Go to the Design tab.

3. Click on the drop-down arrow of the Add Chart
Element option.

4. From the list, select the Axis Title option.

5. You can click on Primary Horizontal to add the title

for X-axis.
. You can click on Primary Vertical to add the title for

Y-axis.
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7. When you click the desired option, a textbox appears.
8. Type the title in it and click outside the chart area.
(c) Data legend

1. Select a chart of your choice. Go to Design now.

2. Click on the drop-down arrow of the Add Chart
Element option.

3. From the list, select the Legend option.

4. Legend can be inserted to right, top, bottom or left.
Select any option according to your choice.

(d) Gridlines

1. Select the chart. Go to Design tab.

2. Click on the drop-down arrow of the Add Chart
Element option.

3. From the list, select the Gridlines option.

4. There are various types of major and minor gridlines
available which can be displayed in vertical direction or
horizontal direction. Select any option according to
your choice and gridlines will appeared in a chart
accordingly.

3. 1.Right click on the Plot Area now. A list will pop up. Select
Format Plot from the list.

2. A Format Plot Area task pane opens to the right side of
the window.

3. Click on the Fill tab, select any option by clicking on its
corresponding radio button. (say, Gradient Fill)

4. Click on the arrow next to Preset Gradients and choose

any colour form the options.

. Choose Type and Direction of the Gradient Fill.

6. Click on Colour option to set the colour with the Preset
Gradient in the Plot area of a chart.

. Click on Border.

. To apply border to the plot area, click on Solid Line.

9. Select the colour of your choice using Color option and set
the other options as per your needs. A border will be applied
to the plot area of a chart.

10. You can see the effects side by side as you do selections in
the task pane.
4. To format data series, follow the given steps :

1. Right click on the Data Series. Select the Format Data
Series from the pop up list.

2.You will see that a Format Data Series task pane has
popped up on your screen; it is on the right side of the

window.
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6

7.

. Click on the Fill tab.
. Select any option by clicking on the corresponding radio

button (say Pattern Fill).

. Select the required pattern. Change the foreground and

background colour by choosing the colour from the
Foreground and Background options.

. If you wish to give a border to your Data Series, go to the

Border>Solid Radio Button.
Choose Border Color and increase the width to see the
effect.

5. To format the legend of a chart, follow the given steps :

1.

2

9.

Right click on the Legend boundary. A Legend task pane
opens on the right side of the window.

. Now, click on tab called Fill and Line.
3.

Go to Fill option and select any option by clicking on its
radio button (say Solid Fill) and choose the colour.

. Go to Border option and select any option by clicking on its

radio button (say Solid Line) and select colour and width of
border.

. You can also apply special effects to the legends by clicking

on the Effects tab.

.The effects are of three types - Soft Edges, Glow
Shadow.
.Click on any effect type and choose the desired effect.

Choose colour of your choice and other options.

. It is also possible to change the position of the legend in a

chart like top, bottom, left or right. For this, click on the
Legend option tab.
Select the desired option where you want to place the
legend in the chart.

6. It refers to the integration of data from various sources so that
all data comes to one destination. An example will clarify the
concept.

1.

2.

Open the worksheets and group them by using the
procedure explained in previous topic.

Click on Sheet 3 tab, change the title of the table as
Consolidated Test Report.

. In sheet 3, select cell B4.
.Click on Data tab. Under Data Tools group, select

Consolidate option.

. A Consolidate dialog box opens.
. From the Function list box, click on the SUM function to

calculate the total of the marks in the test reports of Sem 1

and Sem 2.



7.Click on the Reference field box and select the range
from Sheet 1 (B4:D10). Click on Add. The reference will
get added to the All reference box.
8. Again, click on the Reference field box.
9. Select the Sheet 2 tab and select the range from B4:D10.
10. Click on Add button and the reference will be added to the
All Reference box.
11. Click on OK button.
12. The consolidated data of sheet 3 will look like.
7. Let us see how we can group multiple worksheets:
1. Open a workbook. A worksheet will open named Sheet 1.
2. Add two more worksheets named Sheet 2 and Sheet 3.
3. Now, select the Sheet 1 tab.
4. Now, press Shift key. Hold the key even as you click on the
tab of sheet 3.
5. You will observe that Group of worksheets is created with
three worksheets in it, named Book 1 in the title bar.
. Sheet 1 is active currently. Enter the data.
7.Change the format of table headings. Change the
background colour to yellow. Make the heading text
bold-faced.
8. Apply border to all the cells from A1:ES8.
9. Select column Total and change its text colour to Red.
10. Select the Roll No column and bold the text in it.
11. Click on any worksheet. You will notice that all worksheets
displays the common data with same formatting effects.
Ungrouping Worksheets
1. Now you can right click on the Sheet tab.
2. A pop-up list opens. Click on Select All Sheets option.
3. All grouped sheets will get selected.
4. Again, right click on any Sheet tab.
5. A popup list opens.
6. Click on Ungroup Sheets option.
7.The grouped sheets will became ungrouped. Thus, the
editing done in one sheet will not be applied to any other
sheet.
8. Tiny charts can be added in a cell using the sparklines option. To
insert tiny charts in a cell follow these steps :
MS Excel 2016 supports three types of sparklines :
Line : This type represents data values with or without any
marker for every data point.
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Column : The column type of sparkline represents the data
values in the form of tiny columns.

Win/Loss : The Win/Loss type of sparkline is a binary chart
which represents data values as Win or Loss, where win blocks
are represented by blue squares and little high than Loss blocks
which are represented by red squares.

. Goal seek is a unique concept in Excel 2016. You have already
given a output. You want to find out the input values for the
same. It is also called What-If analysis or Back-Solving. Goal
Seek feature allows you to adjust a value used in a formula to
achieve a specific goal. In simple words, if you know the output
that you want to get by applying a formula and you want to
know what input values are needed by a formula to get the
output, you can use Goal Seek feature. Let us see how it works :

1. Open a blank worksheet and enter the values as given
below :

m The date of sales by an employee per month has been
given. We have to find the sales for one quarter, the total
sales for every month and the total sales value. (grand
total)

= Calculate the total for Quarter 1 for the month January
to March using SUM() function.

= Also, calculate the total for Quarter 2 for the month April
to June using SUM() function.

= Calculate the total month wise also in Totals row.

= Find out the grand total now.

2. Now, our grand total is 618. Using Goal Seek feature, we
will determine the changes in C4 in order to get the grand
total of 650.

3. Go to Data tab.

4. Go to Forecast group and click on what if analysis in it.
A drop-down list will appear , select Goal Seek in that list.

5. A Goal Seek dialog box will open.

6. In Set Cell text box, type the address of a cell on which you
want to apply the goal seek (For example: J9). But the cell
chosen for the Goal Seek must be a formula cell.

7.In To Value text box, type the value we want on that cell.

8. Click in By Changing Cell textbox, and click in the cell in
the worksheet which we want to change to get the desired
result. Click on cell C4 or type C4 in this field.

9. Click OK button.

10. A dialog box will pop up on the screen. It will show the total.
This total was adjusted to get a value 650 click on OK now.

4
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Control Statements in Small Basic

Let Us Answer

Multiple Choice Questions :
1.

(0), 2. (a), 3. (b), 4. (0), 5. (a).

B. Fill in the blanks by choosing the correct word from the
brackets :

1. If, 2. Control, 3. Condition, 4. False, 5. True.

C. Write ‘T’ for true or ‘F’ for false statements :
1.F,2.F,3.T, 4.F, 5.F.

D. Short Answer Type Questions :

1.

3.
4.
5.

Control statements help to make flow of program control. This
is made possible through decisions, repetitions, or to jump from
one section of code to another.

. There are three types of control statements. These are as

follows :
(1) Selection Statements
(i) Jumping Statements
(iii) Iteration Statements
If Then statement does not have a False block.
Label is the name given to the particular statement.

The various selection statements are : If Then, If Then Else and
If Else If ladder.

E. Long Answer Type Questions :

1.

If Then Statement : If Then statement is used to carry out a
logical test (condition) and then take actions depending on the
result of the test.
Syntax
If < condition > Then
<Statements>
Endlf
If Then statement does nothing when the condition is False as it
does not contain the False block. When a program is being
executed, a condition is checked. If the condition is True, the
statements specified after Then are executed. If the condition is
False, it does nothing and the control directly jumps to the
statements written after EndIf.

. Goto Statement

Goto statement is a jumping statement. It helps to break the
sequence by jumping to the statement which is labelled. In such
statements, you need to put a label name on the statement, on
which the control will jump.



Syntax :
Goto <Label>

<Label > Statement

In the above syntax, Goto will transfer the control to the
statement having the label name mentioned with Goto
statement. A Label can be a word, number or symbol, which
identifies a location in a program.
If ElselIf ladder
If there are multiple conditions in a single program, then this
statement helps. In order to apply multiple conditions, multiple
Elself statements are used. In this case, if a statement is True,
the statements in its associated block is executed and control
jumps out of the If Elself ladder. If the condition is False, the
control skips the associated statements and jumps to the next
condition.
Goto statement is a jumping statement. It helps to break the
sequence by jumping to the statement which is labelled. In such
statements, you need to put a label name on the statement, on
which the control will jump.
Syntax :

Goto<Label>

<Label> Statement

In the above syntax, Goto will transfer the control to the
statement having the label name mentioned with Goto
statement. A Label can be a word, number or symbol, which
identifies a location in a program.
Example : Here is a program in Small Basic to print numbers 1
to 5.
basic 2.sb - D:\Small Basics\basic 2.5b
1 -
Increment:
p=P +
(Pe=
TextWind
Incremen




More on Small Basic

Multiple Choice Questions :

1. (a), 2. (b), 3. (c), 4. (b), 5. (¢).

Fill in the blanks by choosing the correct word from the

brackets :

1. Iteration, 2. pixels, 3. F5, 4. (0, 0), 5. FontFamily.

Write ‘T’ for true or ‘F’ for false statements :

1.F,2.F,3.T,4.T,5. T.

. Write down the syntax for the following :

1. GraphicsWindow.FontBold =“value”

2. GraphicsWindow.Width="“value”

3. GraphicsWindow.BackgroundColor="“Color name”

4. GraphicsWindow.FontColor=“value”

5. GraphicsWindow.PenColor = “value”

Short Answer Type Questions :

1. Business All-purpose Symbolic Instruction Code.

2. Various types of control statements are : selection, jumping and
Iteration statements.

3. Iteration statements are also called looping statements. It is
used when there is a need to repeat a task until some condition
is satisfied.

4. For Loop with Step Statement :

If you want to increase or decrease the variable value other than
1, you can use the Step command in the for statement. Step
value is an optional statement, which may have either a positive
or a negative value.

5. We have done simple programming to display alphanumeric
data and do calculations. But Small Basic can be used to do
more than doing simple programming of displaying text and
numbers. It can be used to create graphics of different colours,
colourful text by specifying its Font colour, size, style, different
shapes, designs and sound as well.

Long Answer Type Questions :

1. For loop is Count-Controlled Loop. It is used when you know how
many times you want the computer to repeat the instructions.
The set of statements is executed for a specific number of times.
Syntax :

For <Loop Counter> = <Initial Value> To <Terminal Value>
For loop starts with the keyword For. The statements written
between For and EndFor is called the body of For loop. The loop



counter variable controls how many times the loop runs. In this
looping statement, you take a variable, assign it an initial value
and a terminal value and let the computer increment the
variable for you. Every time the computer increases the value of
the variable by 1, the statements between For and EndFor will
get executed.

Flowchart :

Initialization

False

True

Statements

v

Example : Write a program to print a table of 5.
Untitled *
i
TextWindow.WriteLine( +1+" + * 1)

While loop is the looping statement, in which a set of
instructions are executed repeatedly until some condition is
satisfied. When the condition is False, the loop terminates.
Syntax :

While <condition>

{

Statements

}
Flowchart :

y

‘ False

True

Statements

v




The flowchart on the previous page makes it clear that first the
condition is checked. If the condition is true, the statements are
executed and control goes back to the condition. If the condition
is false, the control comes out of the loop.

Example :

Untitled *
1 X=
2 While (x <= 10)
TextWindow.WriteLine(x)
4 X=Xx+1
5 Endwhile

B ' C\Users\KULDIP\AppData\Local... - O X

ss any key to continue...

3. Subroutine are used in those cases where we have to execute the
same steps over and over again. These instructions can be called
and executed anywhere in the program whenever needed. By
creating subroutines in a program, you reduce the size of the
program. Despite using the same instructions again and again in
a program, you can create its subroutine and can call the
subroutine and execute the instructions in it as and when

required.
Syntax :
SUB <subroutine name>
Statements
EndSub



4.

Example : Write a program to find the factorial of given
number

Untitled *
1 TextWindow.WriteLine("Enter the valu fn: ™)
2 n = TextWindow.ReadNumber()
3 Factorial()

4 TextWindow.WriteLine(“Fatorial of " + n + " is: " + Fact)
5 Sub Factorial

; Fact = 1

7 For i =2 Ton

8 Fact = Fact * i

9 EndFor

10 EndSuﬂ

For Loop with Step Statement :

If you want to increase or decrease the variable value other than
1, you can use the Step command in the for statement. Step
value is an optional statement, which may have either a positive
or a negative value.

Example : Write a program to print the numbers in reverse
order.

Untitled *
1 For 1 = To 1 Step -
TextWindow.WriteLine(1i)
3 EndFod

When you use the Write() function to display the output, the
output is displayed in Text Output area. To display the text in
Graphics window, you can use the DrawText() method. With
the help of this method, you can draw and display the text and
numeric values in Graphics Output area. Specify the position
where the text will be displayed by specifying the x and y
coordinates.
Syntax :

DrawText(x, y, “Text:)
where,

x : is the x coordinate

y : is the y coordinate

(=]



Example : Write a program to display the text “Good Morning”
in Graphics Window.

Untitled *

1 GraphicsWindow.
GraphicsWindow.
3 GraphicsWindow.
GraphicsWindow.
GraphicsWindow.
6 GraphicsWindow
GraphicsWindow.
GraphicsWindow.
GraphicsWindow.

Show()

Height =

Width
BackgroundColor
FontName =

.FontSize = 4

FontItalic = "
PenColor =
DrawText(120, 120, "I

6. GRAPHICS WINDOW

The graphics window is made up of tiny dots called pixels. A
group of pixels together makes an image which is seen by you.
The quality of the image depends on the number of pixels in it.
More number of pixels will make a high-resolution image which
will improve its quality. The low-resolution image consists of
less number of pixels. Graphics Window is made up of pixels. A
Graphic Window can be displayed in which we can create
designs and graphics patterns.

Graphics Window is divided into x and y coordinates. By
default, the Graphics window is 624 pixels wide (x) and 444
pixels high (y). At the top left corner, the x and y coordinates are
(0,0). The x coordinates increase when we move from left to
right. The y coordinates increase when we move from top to
bottom.

Display a Graphics Window

To display or show the Graphics window, you need to use
Graphics Window.

Show () function : This function will open a Graphics
window in which you can draw various shapes, colourful lines
and text.

While Loop

While loop is the looping statement, in which a set of
instructions are executed repeatedly until some condition is
satisfied. When the condition is False, the loop terminates.
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Syntax :

While <Condition>

{

Statements

¥

For Loop

For loop is count-controlled loop. It is used when you know how
many times you want the computer to repeat the instructions.
The set of statements is executed for a specific number of times.
Syntax :

For <Loop Counter> = <Initial Value>To<Terminal Value>

General Activity

How is Small Basic easier and interesting than other
programming languages? You may take the help of the
internet and answer the above question.

1. Size, 2. Variables, 3. Events, 4. Libraries, 5. Type system. [

6. Working With Flash CS6

A. Multiple Choice Questions :

1. (o), 2. (a), 3. (c), 4. (a), 5. ().

B. Fill in the blanks by choosing the correct word from the
brackets :

1. 550*%400, 2. Library, 3. one, 4. Control, 5. Single.

C. Write ‘T’ for true or ‘F’ for false statements :

1.F,2.F,3.T,4.T,5. T.

D. Short Answer Type Questions :

1. Timeline controls the contents over time in layers and frames.

2. When you open a new Flash document, you can see a Layer 1 in
the Timeline. A single frame on the timeline can have multiple
layers. Graphics and other elements can be added on different
layers. Further, the combined content of all layers can be seen
on Stage.

3. Playhead is displayed in red colour frame with a red vertical line
as you can see in the figure above. It is used to represent the
current frame opened on the stage. When you play the movie, it
moves as the movie proceeds from left to right direction. You
can set the frame rate to control the speed of the movement of
the playhead. You can also drag the playhead to watch the

animation.




4
5. 1.
2.
3.
4.
5.
6

7.

1.

. Library contains the symbols for future use.

Click on Start button, a pop-up list opens.

Select Adobe Master Collection CS6.

Now click on Adobe Flash Professional CS6.
Adobe Flash Professional CS6 screen opens.

Click on ActionScript 3.0. Under Create New section, a new
blank file will get opened.

. Each object you create or insert on the stage has some

properties. These properties can be viewed or changed by
opening the Property Inspector or property Panel and do the
necessary changes. All the objects and graphics may have
different properties.

Animation is nothing but an illusion of the movement of still
images in a fast sequence.

E. Long Answer Type Questions :

1.

2.
3.
4,

[© )]

10.

11.

12.

13.

Click on File. A drop-down menu will appear. Select New
from that list.

The New Document dialog box opens.

Click on Action Script 3.0 option from General tab.
Now, select frame rate, background colour, ruler units,
height and width of your choice. Click OK now.

. An Untitled document will be opened in the window.
. Go to Modify>Document option.
. The Document Settings dialog box will pop up before

you, on the screen.

. Enter the values of height and width, they are to be added in

the option called Dimensions.

. Now, click on Ruler unit. A drop-down list will pop up. The

options - millimetres, centimetres, points, inches and pixels
have been displaced in the in that list. Select any one
option.

In Match option, click on the Printer radio button, if you
want to set the stage size to the maximum available print
area.

Click on the Background Color to change the
background colour of the stage by selecting from the colour
palette.

Click on the Frame Rate value to change the speed of the
movement of the animation in frames per second. The
default value is 24fps.

Click on the Auto-Save checkbox, which will enable the
Auto-Save feature of Flash document. This feature will
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14.

automatically save the Flash document at regular intervals
of 10 minutes.
Click OK button to apply the setting to the document.

2. When we create a drawing, two objects are created, one is Fill
and other one is Outline. You can group them together to make
a single object.

1

6.
7.

. In the Tools panel, select the tool called Brush. Now, go to

Properties Inspector. Select the Brown Fill Colour,
Also, change the style to Hairline. Now, you can draw the
flower stem.

. Similarly, draw the flower petals using Brush Tool with

Yellow Fill Color.

. You can see that they both are the different objects.
. Now combine them by selecting the Selection Tool from

the Tools Panel and double click on the Flower petals.
Drag the flower petals over the top of the flower stem to
group them together.

. The flower petals have already been selected. Click on the

flower stem now. So, them and petals are selected
together.
Now go to Modify> Group option.

The objects you selected (flower petals and flower stem)
will be grouped and become a single object.

3. This utility has a colour palette. It has a range of colours. Use
these colours in objects. You can also merge colours. Gradients
are basically formed by mixing more than one colour in an
object. There are in-built gradient presets available, but you can
also create your own gradient by selecting the colours of your
choice and add them in the Swatches Panel.

Let us see how to fill Gradient colors in an object :

1.
2.
3.
4.

5.

Create a circle with the help of Oval tool.

Select the circle.

Go to Tools Panel. Select the Paint Bucket Tool from
that panal.

Go to Properties Instructor and select the Fill Colour
to open the colour palette.

Select the Gradient effect at end of the Fill Colour
swatch and that will be applied on the object.

4. Yes, it is possible to create a user defined Gradients. To create
user defined gradient, follow these steps :

1.
2.
3.

Open a Flash document.
Create a circle by using Oval Tool and select it.
Click on window in the menu bar. Now, click on colour.



4.
5

6

9.
10.

11.
12.

13.
14.

. (@)

(b)

()

(d)

A Color panel is opened in a window.

. Click on the arrow next to Color Type and choose Linear

Gradient or Radial Gradient from the list.

. Click on the Left Pointer which appears on the below left

side of the gradient bar. A Color Palette opens. Choose any
one colour (say Red).

. Now, double click on the Right Pointer and choose Yellow

colour from the Colour Palette.

. You can adjust the slides as per your need to finalize the

colour blends of the gradient.
In Flow section, you can see three options: Extend,
Reflect and Repeat. Select any one as per requirements.
Click on the drop-down arrow on the upper right corner of
the Colour panel bar.
From the list, select the Add Swatch option.
Your newly created gradient is created and added to the
Swatch Panel with existing gradients.
The effect can be seen in the circle selected by you.
Similarly, you can create Radial gradient and add in the
Swatch Panel.
Changing the centre of gradient
1. Move the mouse pointer to the center point of the
Gradient.
2. Now, click the left button of mouse and at the same
time drag the center point in the required direction.
Changing the gradient width
1. You can see a small arrow on the right side of the
selection of the object, called Width Adjustment
Handle. Move the mouse pointer on it.
2. The shape of the pointer will change into a double -
sided arrow
3. Click on left mouse button and drag the mouse inward
or outward to adjust the width of the gradient.
Rotating the gradient fill
1. You can see a Rotation Handle at the upper right
corner of the selection of object.
2. Move the mouse pointer on the Rotation Handle.
3. The shape of the mouse pointer will change to circle
with arrows.
4. Click left mouse button and drag the selection to rotate
the gradient.
Importing graphics on a stage
1. Open a blank Flash document.
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. Go to File>Import>Import to Stage option.
3. The Import dialog box opens.

4. Browse through file names select one file of your choice
from that list.

5. Click Open button.
6. You will get the file on the stage.

6. Tint Tweening feature of Flash is used to modify the colour of a
symbol. We have used a word ‘symbol’ here, because this
feature works only with symbols and not the objects you have
created on the canvas.

1.

2.
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10.

11.

12.
13.
14.
15.

16.
17.

18.

19.

Open the Tools Panel. Pick the Text Tool from this
Panel.

Change the Font family, style, color and size of the
text.

. Type some text on the stage. (say Good Morning)

. Click on the Selection Tool from the Tools Panel.

. Select the text by double clicking on it.

. Click on Modify>Convert to Symbol option to convert

the text into symbol.
A Convert to Symbol dialog box opens.

. Type the name for the symbol (say Text) and click OK

button.

. Text will be converted into symbol and automatically saved

in the Library.

Click on Frame 40 in the Timeline. Insert a frame by
right-clicking on it. Now, press insert frame.

Insert a keyframe in Frame 10, Frame 20, Frame 30 and
Frame 40 by right clicking on it and select the Insert
Keyframe option.

You will see small solid black dots indicating the keyframe
in the timeline.

Select the Frame 1 and click on the Text symbol.

Open Properties Panel.

Go to colour Effects and click on the drop-down arrow of
the style option.

From the drop-down list, select Tint option.

Now, move the slider of Tint to 100%, Red to 0, Green to O
and Blue to 255.

Select Frame 10 now. Add tweening by moving the slider of
Red to 255. Also, change Green 0 and Blue to 0.

Now select the Frame 20 and add tweening by moving the
slider of Red to 0, Green to 255 and Blue to 0.



20.

21.

22.

23.

24.
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13.
14.

15.

16.

17.

18

Now select the Frame 30 and add tweening by moving the
slider of Red to 0, Green to 0 and Blue to 255.

Now select the Frame 40 and add tweening by moving the
slider of Red to 255, Green to 0 and Blue to 0.

Now, right click on Timeline between Frames 1 to 10. Now,
select Create Motion Tween from the pop-up menu that
appears or screen.

Similarly, right click at any place between Frame 10 and
Frame 20 , then Frame 20 and Frame 30, then Frame 30
and Frame 40 and select the Create Motion Tween
option from the pop-up list.

Go to Control>Test Movie>Test to preview what Tint
effects you have created on the Text symbol.

. Select the Text Tool from the Tools Panel.
.Click Properties Inspector now. Change the Font

Family to Comic Sans, Style to Bold, size to 40 and colour to
purple.

. After setting the properties of the text, its time to type the

text.

. Select Frame 1 in the Timeline.

. A textbox appears on the stage with a cursor in it.

. Type text Computer System in it.

.Now select Frame 40. Right-click on it. Select Insert

Keyframe option from the list displayed on the screen.

. Type the text Technology in it.
. Click on Frame 1.

10.
11.
12.

In the list of Modify, select Break Apart.

The letters in a word will get separated.

Again, select the Break Apart option from Modify menu.
The text gets converted into shape.

Select Frame 40.

Select the typed that now. Now, select Break Apart from
the list that turns up after clicking Modify.

From the menu of Modify, pick the Break Apart option.
The text will acquire a shape.

To create the Shape Tween, right click between Frame 1
and select the Create Shape Tween option from the
pop-up list.

You will notice that a Green coloured solid panel appears
between Frame 1 and Frame 40 with an arrow in it
indicating a Shape Tween in it.

.Go to Control>Test Movie>Test to preview the

changing of shape of the text.



. Open a blank Flash document.

. In the Tools Panel, select the Text Tool option.

. Click on the stage, a text box appears along a cursor in it.

. Type the text (say Humanity).

. Go to Tools Panel, select Selection Tool from it.

. Now, double-click on the text; it will be selected.

. Go to Modify>Break Apart option from it.

. The text will be separated into characters.

. Now select each character in the text and convert it into a
symbol by right click on it and select the Convert to
Symbol option from the list.

.You will see a dialog box. It is the Convert to Symbol
dialog box. Write the name of the symbol (Symbol 1). Now,
in the type drop-down menu, select Movie Clip.

11. Click OK button.

12. Select all the characters of the text using Selection tool.

13. Open Properties Instructor.

14. In Filters section, click on the Add Filter button at the

bottom left corner of the section.

15. A pop-up list opens. Select any of the effect you want to

apply (say Blur).

16. Go to the top-right corner and click the drop down button

located there. Select Close Group to close this panel.

17. Now observe the blur effect on the text.

Mindful Activity

Distinguish between Frame by Frame animation and
Tweened Animation. You can take the help of Internet.
Frame by Frame animation : In this class of animation, we
create one image in one single frame and keep adding a small
change in each frame to create the illusion of animation.
Drawbacks of Frame by Frame Animation :

1. It is labour intensive.

2. It creates large files.

Tweened Animation : In Tweened Animation, starting and
ending keyframes are created by user and the in between motion
effects are created by Flash.
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Working With Layers

Let Us Answer

. Multiple Choice Questions :

1. (a), 2. (a), 3. (), 4. (a), 5. (a).

Fill in the blanks by choosing the correct word from the
brackets :

1. One, 2. Red, 3. Building Brush, 4. Masking, 5. Control.

. Write ‘T’ for true or ‘F’ for false statements :

1.T,2.F,3.F,4.T,5.F.

. Write down the purpose of following buttons in a single

line :

. It is used to move a layer.

. It is used to delete a layer.

. It is used to hide layer.

. It is used to create a new layer.

. It is used to lock layer.

. It is used to rename a layer.

Short Answer Type Questions :

1. Alayer is a transparent sheet which contains objects, stacked on
the top of each other.

2. Steps to select a layer are :

1. Go to Timeline and click on the layer. The layer will be
highlighted in the blue colour.

2. Or Select an object on the stage, the related layer will get
selected and highlighted with blue colour.

3. Steps to add new layers in a Timeline are :

1. Click on the New button on the left bottom corner in a
Timeline.

2. You will observe that a new layer has been added above the
active layer. This new (added) layer becomes active.

4. Lock a Layer button is used to lock the contents in the layer in
order to prevent from accidental changes.

5. It is a utility that is used to display or hide some parts of a layer
in Flash. You can use the masking feature to control the content
that you want the viewers to see. You can give the spotlight
effects and transitions by using the mask layer in which a hole is
created through which the underlying layers are visible to the
viewers. The items which can be masked in a layer are a graphic
symbol, filled object, text, or a movie clip.

6. It is used to show all the layers.
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7. To delete a selected layer, click on the Delete layer button.
F. Long Answer Type Questions :
1. Layer is a transparent sheet that has objects.
Steps to rename a layer are :
1. Right click on the Layer name which you want to rename.
2. A pop-up list opens.
3. Click on the Properties option.
4. A Layer Properties dialog box will pop-up on the screen.
5. Type the new name for the layer in Name textbox.
6. Click OK button.
7. Observe that the name of the layer is changed to Wall.

2. When multiple layers are overlapped, then various objects
embedded in different layers come up on the stage. When you
change the order of layers in the Timeline, the order of various
objects on the stage changes accordingly. It means that the layer
which is on top of all the layers, its contents will appear in front
of all the contents of other layers. So, objects of higher layers
appear in front of the objects in the below layers.

Steps to change the order of layers :
1. Select the layer which you want to move by clicking on it
with left mouse button.
2.Drag the layer to move it to the required position and
release mouse button.
3. You will notice that the layer is moved accordingly.
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4.

5.

In this picture, the Layer Snowman goes downwards. Also,
note that Layer Wall is on the top.

Contents of Layer Wall is above and Snowman is hidden on
the back of the Wall.

3. (a) Steps to Hide/Show the layers are :

1.

4.

Click on the Eye icon which appears above the layers. A Red
Cross will appear in the Eye column in all layers. It will hide
all the layers by removing their contents. You will get a
blank stage.

. Now, click the Eye once again. All the contents of all layers

will be displayed on the stage.

. If you click on the small circle in the Eye icon column, a Red

cross appears and corresponding layer will be hidden and
its contents will disappear. This way, you can hide the
contents of individual layers.

Again, click on that Red Cross, it will disappear and
contents will be displayed again.

(b) Lock a layer

1.

2.

3.

Now, click on the Lock icon which is above the layers. You
will see that a lock symbol has came up on all layers. This
proves that all layer contents have been locked.

To lock the individual layer, click on the dot in the Lock
column of the layer to lock its contents.

Click again on the Lock icon to unlock the layers.

4. It is a utility that is used to display or hide some parts of a layer
in Flash. You can use the masking feature to control the content
that you want the viewers to see. You can give the spotlight
effects and transitions by using the mask layer in which a hole is
created through which the underlying layers are visible to the
viewers. The items which can be masked in a layer are a graphic
symbol, filled object, text, or a movie clip.

Creating a Mask Layer :

1.
2.

3.
4.

(&)

Open a blank Flash document.

Now change the background colour of the stage by opening
the Properties Instructor and change the colour to red.
Change the name of the Layer to Text.

From the Tools Panel, select the Text Tool. Now, change
Font Style, font color, font size and font family using the
Properties Inspector of the Text Tool.

. Type the text MASKING.
. Choose the Selection Tool and select the text.
. Go to Modify>Convert to Symbol option to convert the

text into symbol.



11.
12.
13.

14.

15.

16.

17.
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12.
13.
14.

15.
16.

. Using Selection Tool, drag the text to the bottom left

corner of the stage.

. Now, click on Frame 50. Now click on Insert Frame.
. Right click on Frame 1 and select Create Motion Tween.

Move the Playhead to Frame 50.

Now drag the text to the upper right corner of the stage.
Insert new layer and rename it to Mask.

Now open the Tools Panel. From the options present in it,
choose the Oval Tool. Now, choose a Fill Color.

Now draw an oval shape in the middle of the stage. It must
be noted that the width of the oval must be larger than the
text.

Now, right click on the Layer Mask from the Timeline. Now,
select the Mask option from the menu that pops up on the
screen.

The selected layer will be converted into a mask layer which
will take the Text layer underneath. Both the layers are
locked automatically.

Now, go to Control. Click on Test Movie in the options
present in it. Now, click Test.

. Open a blank Flash document.

. Click on File, Now, go to Import> Import to stage.

. An Import dialog box opens.

. Browse and select the image you want to choose to import

on the stage.

. Click Open button.
. Select the Free Transform Tool now. Now, click on the

image. Drag it to make it fit on the stage.

. Select the Layer and rename it as Scene.

. Select Frame 50, right click on it and insert a new frame.

. Lock the layer.

. Create a new layer and name it Polymask.

. Use a PolyStar Tool. Draw a polygon in the middle of the

stage with its help. Now go to the Tools Panel. Select a Fill
colour from the options present there.

Now select the Polygon using Selection Tool.

Go to Modify>Convert to Symbol option.

Give the name ‘Polygon’ to the symbol. Now, select
Graphic Style. Go to the Convert to Symbol dialog
box. Click OK in the dialog box.

Reduce the size of Polygon using Free Transform Tool.
Right click on Frame 50 and select Insert Keyframe
option from the pop-up menu.



8.

17. Increase the size of Polygon using Free Transform Tool.

18. Now, right click on Frame 25. Now, in the list that appears,
select the option Create Classic Motion Tween.

19. An Arrow line will be displayed in the frames.

20. Now, go to Property Inspector. Select the option CW in
the Rotation field.

21. Right click on the Polymask layer and select the Mask
option from the pop-up list.

22.You will see that the Scene layer has come under the
Polymask layer.

23. Go to Control>Test Movie>Test to see the effects of
masking.

. Now, we know that we can use Frame by Frame method to

create animations. We can also create them using the Tween
animation method. Both these methods are called Linear
Frame by Frame view.
Onion Skinning, on the other hand, is a technique in which you
can view more than just one frame at a time. It allows you to
view multiple frames of an animation sequence at once. Using
this method, you can create a faint ghost image of the previous
frame with whose help you can place the art work in new
frames. In this way, an animator can make a decision on how to
make some changes in the image on the basis of previous image
in sequence.

4

Introduction to HTML 5

Let Us Answer

Multiple Choice Questions :

1. (b), 2. (a), 3. (&), 4. (b), 5. (c).

Fill in the blanks by choosing the correct word from the
brackets :

1. Hyper, 2. <h2>, 3. Black, 4. .html, 5. <title>.
Write ‘T’ for true or ‘F’ for false statements :
1.F,2.T,3.F, 4.F, 5. T.

Give the syntax to perform the following :

1. <body TEXT = “red”>

2. <hr ALIGN = “Left” SIZE = “r">

3. <B>

<Font Color = “blue”>



E. Short Answer Type Questions :

1.

Internet is based on Client/Server Architecture. A client is a
user’s computer who sends the request to the server which
responds by providing the required data to the client. The server
stores files and information in the form of websites.

. Web Browser is a software application which is used to locate,

retrieve and present the contents on world wide web.

. Hyper Text Markup Language.
. A webpage is an electronic page contain the information which

may be text, graphics, audio, video etc.

. HTML or Hyper Text Markup Language is a standard markup

language which describes the structure of web pages using
markup. This language is used to create web pages, also called
Hyper Text Documents. These documents can be viewed
through web browsers like Internet Explorer, Google Chrome
etc.

. A hyperlink is a link by clicking on which you move to the linked

page.

. A tag with no closing tag is called Empty tag. For example,

<br>.

. A tag with both starting and ending tags is called container tag.

For example, <B>.

. Tag Attributes are the tag properties which are used along with

the related tag. These are the keywords which are enclosed in
the starting tag, and are used to modify the default tag
properties. These attributes are totally optional. They are used
when some specific property of the tag needs to be changed.
Attribute value must be enclosed in double quotation mark.

10. Italic tag is used to display the text little slanted. <I>.....</I>.
11. <br> tag:

You can introduce a line break into your HTML document with
the help of <br> tag. This tag is an empty tag.

Syntax :

<br>

<p> tag:

To display a long piece of text on a web browser, a paragraph
element <p> is used, which marks a block of text as a
paragraph. To mark the end of a paragraph, </p> element is
used. The text starts from a new line and adds some extra space
at the starting of the paragraph.

Syntax :

<p> Text </p>



F. Long Answer Type Questions :
1. Hyper Text Markup Language was developed by Tim Berners

3.

Lee at CERN in November 1990. The journey of HTML began
as GML (General Markup Language) in 1980s. Then some
modifications and new features were added in it and a new
version, namely SGML (Standard General Markup Language)
was established in 1986. Then, Lee and his team worked on it,
re-designed it and create a language called Hyper Text Markup
Language. The standard version of HTML was HTML 2.0 which
came into existence in 1995. Later, newer versions came with
new features and modifications. HTML laid down the
foundation of World Wide Web (WWW). This was helpful for
scientists in different universities to access each other’s research
documents, by linking the text to research documents with
relevant document of other researchers.

. <html>

<head>
<title> Title of a web page </title>
</head>
<body>
Body of a web page
</body>
</html>
(i) <html> : This tag is the root element of an HTML page.
Everything is written within <html> tag. It must have a
closing tag </html>
(ii) <head> : This tagis used to define the heading of a page.
(iii) <title> : This tag defines the title of the document.

(iv) <body> : This tag is used to define the body section of the
document.

1. Click on Start button>All apps.
2. Select Windows Accessories>Notepad option.
3. A Notepad window will open.
[ Untited - Notepad =)
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4. Now type the HTML code for creating an HTML document
as shown in the figure.

_1
File Edit Format View Help

<html>
<head>
<title> First HTML Page</title>
</head>
<body>

This is the first page of the HTML document.
</body>
</html>

5. Save the HTML code that you have typed.
4. Yes, it is important to save HTML document. To save HTML
documents, follow these steps :
1. Click on File menu from the menubar.
2. From the drop-down list, select Save or Save As option.

— = [Page</title>

Save As..

Page Setup first page of the HTML document.
Prirt. CieP

Exit

3. A Save As dialog box opens.
4. Type the name of document in Filename textbox and save
it with an extension “html’.

0 save bs X
4 @ * ThsPC * Documents v O | Search Docu »
Organize = MNew folder = -
W This PC ®  Name : Type
= Deskiop Corel File folder
% Documents Custom Office Templates ! File folder
% Downloads My Falettes 447218 S30PM  File folder
& Music
& Pictures
B Videos v £ »
file nare: RS v
Save as type: Text Documents (*.txt) o
y— trcs: o] | o

5. Click on Save button.



5. 1. Click on Start button>All apps.
2. Click on Microsoft Edge.
3. A Microsoft Edge window opens.
4. Type in URL file:///C:/ drive name in which your file is
present and press Enter key from the keyboard.

CECES T —a w

- e

5.1t will display the list of all the files and directories which
are present in C: drive.

M ow oS - o *
Home  Share  View (7]

= w~ o L. > ThisPC » OS(C) » w ) Seach 05 (C a2
Class 7 * Mame Date mocified Type
A
Pps Apps
oz DELL
% Dropbox Drivers
eeColorTables g 14 PM  File folder
& OneDive HTML documents 5/3/2018943PM  File folder
= This PC Intel 4/5/2018 10:12 AM File foider
m Desktop Ferflogs 0
Fil 4
% Documents Program Files
Program Files (x36) 4
& Downloads
Recovery 4
& Music Ucars 4
« Plctures Windows 4
B Videas Windows10Upgrade Te!
13items 1 item selected [E=

6. Now navigate through the files and directory to get the
HTML file you want to open.
7.Click on the HTML file and the HTML document will be
displayed on the screen.
6. (i) BGCOLOR : This property is used to set the background
colour of the HTML element. The value assigned to the attribute
may be in the form of colour name or hexadecimal code.



Syntax :
<body BGCOLOR = “colour name”>
Or
<body BGCOLOR = “hex code”>
(ii) TEXT : We use this attribute to change the text colour of

entire web page. The value assigned to this attribute can be
a colour name or hexadecimal code.
Syntax :
<body TEXT = “value”>

[ u«:m-ump-d‘__m ______l e e |
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<html>
<head>
<title> Computer =-=- A Machine </title>
</head>
<body bgcolor="pink" text="blue">
Computer is an electronic machine that helps to perform calculations.
It has become a necessity for every perscn to live in this digital world.
</body>
</html>

| . b i
Computer -- A Machine x t

c @ @ file:///C:/Users/VivShe - @ W mwoBg =

Comp is an el i hine that helps to perform calculations. It has b a ity for
every person to live in this digital world.

(iii) BACKGROUND : With this property, we can add an image
in the background of an HTML document. For this,
BACKGROUND attribute is used with <body> tag. The
value to be assigned must be a complete path where the
image is stored.

Syntax :
<body BACKGROUND = “path”>
7. <font> tag :
This tag is used to format the text of a web page. Formatting the
text means to change the looks of the text by displaying it in a
presentable manner, so that your web page looks more



attractive. This can be done by changing the font face, its colour,
applying style to the font or changing its size.

Attributes of <font> tag :

(i) FACE : This attribute is used to change the type face of the
text contained in this tag. The value assigned to this
attribute is the specific font face.

Syntax :
<font FACE = “font name”>
Web page contents

</font>

(ii) SIZE : This attribute is used to change the default size of
the text contained in this tag. You can assign the value
which must be from 1 to 7, where 1 indicates the smallest
value and 7 indicates the largest value.

(iii) COLOR : This attribute is used to change the default colour
of the text enclosed in this tag. The value assigned to this
attribute must be colour name or hexadecimal code.
Syntax :
<font COLOR ="“value”>

Web page contents
</font>
8. Heading tag (<h1> to <h6>):

This is a heading tag. It is used to define different heading levels

in an HTML document. This is basically used to emphasize the

text. There are six levels of headings from <hl> to <h6>.
<hl> represents the top level of heading and is the most
prominent heading. <h6> represents the bottom level of
heading and is the least prominent heading. <h1l> is mainly
used for main headings and rest of the header tags are used for
sub-headings or sub-sub headings.
Syntax :
<hn> Heading text </hn>
Where, the value of ncanbe 1, 2, 3, 4, 5, or 6.

9. <hr> tag:

This tag is used as a separator between blocks of text. The <hr>

element draws a horizontal line across the page. It is an empty

element and has no end tag. One time use of <hr> will draw a

single line. To draw two lines, use it twice. You can use this tag

anywhere in a document.

Syntax :

<hr>



Attributes of <hr> tag :
(i) ALIGN : This attribute is used to set the alignment of the
line, i.e. Left, Right or Center.
Syntax :
<hr ALIGN = “value”>
Here, value can be left, right or center.

(ii) SIZE : This attribute helps to specify the thickness of the
horizontal line. The value assigned to the SIZE attribute
must be set in pixels.

Syntax :
<hr SIZE = “value”>

(iii) WIDTH : This attribute helps to set the length of the
horizontal line. The value assigned to this attribute must be
set in pixels or percentage.
Syntax :
<hr SIZE = “value”>

(iv) COLOR : This attribute helps to set the colour of the
horizontal line. The value assigned to this value can be color
name or hexadecimal code.

Syntax :
<hr COLOR = “value”>

General Activity

Find and write down various hexadecimal codes for the
given colours with the help of Internet.
1. # 008000, 2. # 0000FF, 3. # EE82EE, 4. # O0FFFF,
5. # FFFFFF, 6. # 808080, 7. # FF0000, 8. # FFA500,
9. # FFFF00, 10. # 000000. |
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Do it yourself.

Annual Model Test Paper

Do it yourself.



