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Chapter 1
A. Fill in the blanks:
 1. Physical 2. Bits 3. Software, Hardware
 4. CPU
B. True or False:
 1. True 2. False 3. False 4. False
C. Do it yourself.
D. Application based question:

1. She can use Printer for the same and it is an output device.
E. Tick mark:
 1. An input 2. Byte 3. Braille Embosser
 4. 3D Printer 5. Gigabytes
F. Answer the following:

1. Software and Hardware are the two major components of a 
Computer System.

 The physical parts of a computer system are called Hardware 
and the term ‘Software’ refers to the set of instructions that tells 
the computer about the tasks to be performed and how these 
tasks are to be performed.

2. The four main characteristics of computer are:
 (a) High Speed   (b) Accuracy
 (c) Storage Capability  (d) Diligence
3. We will check the storage capacity of a Hard Disk by 

performing a double click on the Computer icon available on 
the Desktop. A window will be opened that displays icons of 
all hard disk.We can see the size of our hard disk by making a 
right click on its icon and selecting the Properties option from 
the Context menu.

4. (a) OCR: OCR stands for Optical Character Recognition. It is a 
type of Scanner which scans handwritten or printed text on 
paper and converts it into actual text which can be edited 
using a word processor.

(b) Smart Card Reader: Smart card Reader is a special machine 
that can easily read smart card information and verify it with 
the already stored information inside the computer system.

(c) 3D Printer: A 3D Printer is a computer-aided 
manufacturing device that creates three dimensional objects 
from	a	digital	file.

Computer Login-6
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5.	The	use	of	Computers	in	the	following	fields	are	as	follows:
(a) Banks: Computers are used in Banks to create and maintain 

the accounts of customers.
(b) Healthcare: In the healthcare sector, computers are used to 

diagnose complicated diseases with more accuracy.
(c) Education: In the Education sector, computers are 

effectively used as teaching aids.
(d) Entertainment: In the Entertainment sector, computers are 

used for animation, graphical and sound technologies for 
movies.

Chapter 2
A. Fill in the blanks:
 1. Program 2. Four 3. Machine 4. Assemblers
 5. High Level 6. Assembly 7. Syntax 8. Off, On
B. True or False:
 1. True 2. False 3. True 4. False
 5. True 6. False 7. True 8. False
C. Application based questions:
 1. She must have used either C, C++ or Java.
 2. He is using Fourth Generation Language.
D. Tick mark:
 1. Source Program 2. Interpreter
 3. Object Program 4. John W. Tukey
E. Answer the following:

1.	Machine	 language,	 a	 first	 generation	 language	 is	 the	 only	
language that a computer understands.

2. Assembly language uses symbolic codes whereas machine 
language is completely based on Binary language.

3. The important features of High Level language are:
 (a) Simple and User friendly Language
 (b) Machine Independent Language
4. An Interpreter translates the program line by line whereas a 

compiler translates the whole program at once.
5. The three characteristics of Fourth Generation Language are:

(a) Highly User friendly and independent of any Operating 
System.

(b) Very high speed of execution.
(c) The process of software development is time reducing and 

cost saving.
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Chapter 3
A. Fill in the blanks:
 1. Organise 2. Copying 3. Windows 10
 4. Send, Receive 5. Pictures
B. True or False:
 1. False 2. True 3. False
 4. True 5. False
C. Application based questions:

1. She will use Microphone for the same.
2. The best way to search her project is to type the project name in 

the Start menu Search Box.
D. Tick mark:
 1. Disk Cleanup 2. Aero Peek 3. Jump List
E. Answer the following:

1.	Windows	Media	Player	runs	and	organises	digital	media	files	
available in the Computer’s memory.

2. Ripping a CD refers to the process of copying data from a CD 
to a Computer whereas Burning a CD refers to a process of 
copying data from computer to CD.

3. Windows Media Center is used to watch TV, movies and other 
video content on our PC.

4. In Windows 7, we can display two application windows side by 
side using the following steps:
(a) Open any two applications one by one. Make any one 

application window active.
(b) Right click anywhere on the blank portion of the Taskbar.
(c) Click on the Show windows side by side option from the 

shortcut menu.
 By doing this, both application windows will be displayed side 

by side.
5. The term ‘Disk Cleanup’ refers to a process of removing 
unnecessary	program	files	from	the	Hard	disk	of	a	Computer	
System.

Chapter 4
A. Fill in the blanks:
 1. Main Document 2. Tab 3. Field
 4. Tick 5. Right
B. True or False:
 1. False 2. True 3. True 4. True 5. False
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C. Application based questions:
1. She will add the contact details of these new clients in the Data 

Source.
2.  (i)  Create

(ii) This option pulls the information from the Outlook contacts 
list into our document.

D. Tick mark:
	 1.	Record	 2.	Merge	field	 3.	Type	a	new	list
 4. Pamphlets 5. Mailings tab
E. Answer in one word or a sentence:
 1. Data Source or Mailing List
 2. Mailings tab
 3. Print Documents option 
 4. Field
F. Answer the following:

1. The term ‘Mail Merge’ refers to a process of sending the same 
letter to a number of people at different addresses.

2. Main Document and the Data Source are combined while using 
the Mail Merge feature.

3. Data Source consists of a mailing list. The data is organised in a 
tabular	form	along	with	the	field	names.

4. The Main Document contains the text that we wish to send to 
the Recipients.

5. The main steps involved in Mail Merge are creating a Mail 
merge document, creating Recipient’s list and inserting Merge 
fields.

6. We should follow the given steps to create a new Recipient list 
for the main document:
(a) Go to the Mail Merge task pane and select Type a new list 

radio button under ‘Select Recipients’ section. After that, 
click on the Create button.

(b) The New Address List dialog box appears on the screen. 
Click on the Customize Columns button to remove or add 
fields.

(c)	Enter	 data	 in	 the	 respective	 fields	 and	 click	 on	 the	New	
Entry button.

(d) Enter the records and click on OK button.
(e) A Save Address List dialog box will be opened. Type a name 

in the File name: text box and click on the Save button.
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Chapter 5
A. Fill in the blanks:
 1. Insert Table 2. Pen Color 3. Shading
 4. Plot Area 5. Data Series 6. Draw Borders
B. True or False:
 1. False 2. True 3. True 4. False
 5. True 6. False 7. True
C. Application based questions:

1. He should use Title and Content slide layout for the same.
2. She should change the chart layout for the same.

D. Tick mark:
 1. Cell 2. Legend 3. Alignment
 4. Table Tools 5. Insert 6. Six
E. Answer the following:

1. We can insert a table in a presentation using the following two 
methods:

 Method I: Go to the Insert tab and select Table> Draw Table 
option.

 Method II: Go to the Table option on the Insert tab.A menu will 
appear.

 Drag the mouse over the table grid to select the number of rows 
and columns that we want in the slide.

2. The step by step procedure to add new rows in a table are:
(a) Place the cursor in a table cell where we want to insert new 

rows.
(b) Click the right mouse button. A shortcut menu appears.
(c) Select the Insert option and click either on the Insert Rows 

Above or Insert Rows Below sub-option.
3. We can apply border to a table using the following steps:

(a) Select the cells/rows/columns that we want to modify.
(b) Go to the Design tab and click on the drop down arrow of 

Borders button in the Table Styles group.
(c) Select the All Borders option from the drop-down menu. 

The border will be applied on the selected cells/rows/
columns.

To change the border color, follow the given steps:
(a) Select the table and go to the Design tab.
(b) Click on the Pen Color button in the Draw Border group. 

Choose the desired color from the color palette.
(c) The mouse pointer changes to a pencil shape. Drag the 



47

mouse on the cell border and release the button. The border 
color of the selected table will be changed.

4. Align Text Left, Center, Align Text Right, Align Top, Center 
Vertically and Align Bottom are the six alignment buttons 
present on the Layout tab.

5. Category axis, also known as X-axis or Horizontal axis, is used 
to plot the subject of analysis whereas Value axi or Y-axis is 
used to plot the values.

6. Chart is an effective way to display data in a graphical and 
pictorial form.

 The main components of a Chart are:
 (a) Chart Area   (b) Category Axis
 (c) Value Axis   (d) Data Series
 (e) Category Name  (f) Plot Area
 (g) Legend   (h) Chart Title
 (i) Gridlines
7. We can delete the default data of a datasheet by moving the 

mouse pointer to the Blank button i.e., upper left corner of the 
column indicators and click on it. The entire datasheet will be 
selected. After selection, press the Delete key.

8. A method to change the Chart Type are as follows:
(a) Select the Chart and click on the Design tab under Chart 

tools.
(b) Click on the Change Chart Type button in the Type group. 

The Change Chart Type dialog box will appear. Select any 
chart type and click on OK button. The chart will change 
accordingly.

Worksheet 1
A. Fill in the blanks:
 1. Jump List 2. Compute 3. C++, Java
 4. Six 5. Right
B. True or False:
 1. False 2. False 3. True
 4. False 5. True
C. Tick mark:
 1. Cell
 2. Breaking down in small parts
 3. Legend
 4. Source Program
 5. Taskbar
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D. Answer in one word:
 1. Disk Cleanup 2. MS PowerPoint 3. Horizontal Axis
 4. Mail Merge 5. Binary
E. Answer the following:

1. Machine Language is the only language that a computer 
understands. It is expressed in binary form i.e, 0 and 1.

2. Burning a CD refers to a process of copying data from a 
computer to a CD.

3. The text that we wish to send to the recipients is the Main 
Document in Mail Merge.

4. Three new tabs will appear on the Ribbon when we insert a new 
chart in a presentation. These tabs are Design tab, Layout tab 
and Format tab.

5. The three important applications of Computer are:
(a) In the Research sector, computers are used by Scientists 

to perform complex calculations and data analysis with 
precision and accuracy.

(b) In the Education sector, computers are effectively used as 
teaching aids in classrooms.

(c) In the Banks, computers are used to create and maintain 
customer accounts.

F. Write the correct chart components:
 1. Gridlines 2. Value Axis 3. Data Series
 4. Category Name 5. Plot Area 6. Legend

Chapter 6
A. Fill in the blanks:
 1. Transitions 2. Text, Objects 3. Action Button
 4. Microphone 5. From Beginning 6. Play
B. True or False:
 1. True 2. True 3. False 4. True
 5. False 6. True 7. False
C. Application based questions:

1. He should use Objects option for the same which is available 
under the Insert tab.

2. She must use the Microsoft Clip Gallery option for completing 
the task.

D. Tick mark:
 1. Slide Show 2. Animation 3. .wav
 4. Animations
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E. Answer the following:
1. Animation refers to the process of moving objects like text, 

graphics, charts in a slide. It is helpful to highlight important 
points while delivering a presentation.

2. The process of changing one slide to another during the Slide 
Show View is called Transition.

3. We should follow the given steps to insert own sound in our 
Presentation:
(a) Select the slide where we want to insert the recorded sound.
(b) Go to the Insert tab and select Record Audio option from the 

Audio drop down menu which is available under the Media 
group.

(c) Click on the Record button to start recording and click on 
the	 Stop	 button	 when	 we	 finish	 recording.	 Click	 on	 OK	
button.

(d)	The	recorded	sound	file	will	get	inserted	in	the	slide.
4. Action buttons are built-in button shapes that we can add to a 

presentation and set to link to another slide, play a sound, or 
perform some other actions.

Chapter 7
A. Fill in the blanks:
 1. Three 2. Merge & Center 3. Formula
 4. Sheet 5. Column 6. Tab Scrolling
 7. F12
B. True or False:
 1. False 2. True 3. False 4. True
 5. False 6. True
C. Application based questions:

1. She should type the new name ‘Time Table’ by double clicking 
on the Sheet tab and press Enter key.

2. He should use the Autosum option to calculate the expenses 
and perform a subtraction option on the total expenses and 
total money.

D. Tick mark:
 1. AutoSum 2. Left Aligned 3. 1048576
 4. Name 5. Equal to 6. Three
E. Answer the following:

1. Microsoft Excel is one of the most popular spreadsheet 
software. It is widely used to perform mathematical 
calculations.
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2. A Workbook is like a notebook which consists of a number of 
pages whereas worksheets in a Workbook are like pages of a 
notebook.

3. A cell is an intersection of a column and a row in a Worksheet. 
In MS-Excel, a cell can contain upto 32767 characters.

4. The formula bar is a bar that shows the data and formulas that 
we have entered in an active cell. It is different from Name box 
in terms of data shown i.e, Name box displays the location of 
the cell pointer.

5. We can enter three types of data in an Excel worksheet which 
are as follows:
(a) Numbers: Numbers are values that consist of numerals 

from 0 to 9 and the special characters. By default, numbers 
are right aligned in a cell.

(b) Text: Text data may contain alphabets, numbers, spaces and 
special characters. By default, text data is left aligned in a 
cell.

(c) Formulae: A formulae is a mathematical equation involving 
number values, operators and cell addresses used for 
performing calculations on a worksheet.

6. We should follow the given steps to rename a Worksheet:
(a) Double click the Sheet tab that we want to rename. It will be 

highlighted.
(b) Type a new name and press the Enter key.

Chapter 8
A. Fill in the blanks:
 1. Format 2. F4 3. Ctrl+F10
 4. Cancel, Enter 5. End 6. Space
B. True or False:
 1. False 2. False 3. True 4. True
 5. False 6. False 7. True
C. Application based questions:

1. She should use Insert Sheet Columns option from the Insert 
drop down button in the Cells group on the Home tab.

2.	She	should	use	Autofill	method	for	the	same.
D. Tick mark:
 1. Ctrl+A 2. Paste 3. Ready 4. Ctrl
 5. Ctrl+Z 6. Apostrophe
E. Answer in one word or one sentence:

1. To clear the contents of a cell.
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2. F2
3. Using the space between Date and Time.

F. Answer the following:
1.	We	should	follow	the	given	steps	to	make	modification	in	cell	

contents using the Edit mode:
(a) Select the cell and make a double click inside the cell. The 

insertion point will blink within the cell.
(b) Position the pointer at the desired place and change the 

contents.
(c) Press the Enter key. The changes will be entered in the 

current cell.
2. We can insert the multiple columns in a worksheet by selecting 

the same number of columns that we want to insert.
3. Undo command is used to undo the last action performed on a 

Worksheet whereas Redo command is used to quickly reverse 
the last action that we have done using Undo command.

4. We will select a range and non-adjacent cells in a worksheet by 
making the cells active and hold down the Ctrl key while we 
select the other cells.

5. We should follow the given steps to move data in a Worksheet:
(a) Select a cell or a range of cells. Position the mouse pointer at 

the edge of the selected cells.
(b) The pointer changes from a black cross symbol to a move 

pointer symbol.
(c) Drag the selected cell or range of cells to a new destination 

and release the mouse button. The data will be moved to a 
new location.

6. The two methods for copying data in a worksheet are:
 Method I :

(a) Select the cell or a range of cells that we want to copy.
(b) Click on the Copy button in the Clipboard group. The 

moving dashed line will appear around the selected cells.
(c) Go to the cell location where we want to copy. Click on the 

Paste button in the Clipboard group. The text will be copied 
to a new or desired location.

Method II:
(a) Select the cell or a range of cells that we want to copy.
(b) Press Ctrl+C key combination.The moving dashed line will 

appear around the selected cells.
(c) Go to the cell location where we want to copy. Press Ctrl+V 

key combination.The text will be copied to a new or desired 
location.
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7.	Autofill	 is	 the	 easiest	 method	 to	 fill	 data	 in	 the	 cells	
automatically. We can use it in a Worksheet by follow the given 
steps:
(a) Type any week day in a cell and position the Pointer at the 

lower right corner of the cell.
(b) The mouse pointer changes into a thin black cross. Hold 

down	the	left	mouse	button	and	drag	the	fill	handle	up	to	
the	cells	that	we	want	to	be	filled	in.

(c) Release the button.
G. Look at the cells:

1. Formula in C2 =A2*B2

2. Formula in C3 =A3-B3

3. Formula in C4 =A4/B4

Chapter 9
A. Fill in the blanks:
 1. Hypertext 2. Style 3. Value
 4. Container 5. Line Break
B. True or False:
 1. True 2. False 3. True 
 4. False 5. False
C. Application based questions:

1. She will use the following syntax to set a background image on 
a webpage:

 Background-image : value
 Where value = URL(Path of the school image)
2. He will use HTML <img> tag and CSS width or height 

properties for the same.
D. Tick mark:
 1. <p> 2. Text Editor 3. <HR>
 4. CSS 5. Declaration
E. Answer the following:

1. HTML stands for HyperText Markup Language. It is the most 
widely used language to design web contents for the Internet.

2. Tags: Tags are the special keywords enclosed between the 
angle	brackets.	They	contain	elements	which	define	how	the	
information on a web page is displayed.

 Attribute: An Attribute is the property that provides additional 
information about an HTML element. It enhances the 
functionality of a tag.
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3. An HTML element consists of an ON tag, content and an OFF 
tag.

 The two types of HTML element are:
(a) Container Elements: Container elements are those elements 

that include both ON and OFF tags. For example, <HTML>, 
<TITLE>

(b) Empty Elements: Empty elements are those elements 
that contain only ON tag. These elements do not enclose 
any data; instead they do some function on their own. For 
example, <BR> tag.

4.	Heading	 tag	 is	 used	 to	 define	different	 heading	 levels	 in	 an	
HTML document. It is basically used to emphasize the text. In 
HTML, a Paragraph tag is denoted by <P>, used to display a 
long piece of text on a web browser.

5. CSS is a style sheet that provides the set of style rules for 
defining	 the	 layout	 of	 HTML	 documents.	 Using	 CSS,	 we	
can control the color of the text, the style of fonts, the spacing 
between paragraphs, background images as well as a variety of 
other effects. The various methods to apply CSS in the HTML 
document are:

 (a) Inline Method
 (b) Internal or Embedded Style Sheet
 (c) External Style Sheet

Chapter 10
A. Fill in the blanks:
 1. Case Sensitive  2. Computer Program 
 3. Guido Van Rossum 4. Reuse
 5. Reddit
B. True or False:
 1. False 2. False 3. True 
 4. True 5. False
C. Application based questions:

1. /t
2. The two features of Object Oriented Programming languages 

are:
 (a) Concepts of Classes and Objects
 (b) Code Reusability

D. Tick mark:
 1. 1991 2. IDLE 3. Programming
 4. Interactive 5. Classes
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E. Answer the following:
1. A set of instructions that allows the computer to perform a 
specific	task	is	called	a	computer	program.

2. Computer programs are written in a language that 
the computer understands and can execute are called 
Programming languages.

3. Python is an interpreted, object-oriented, high level 
programming language for general purpose programming. 
It has a large library that provides a rich set of modules and 
functions for rapid application development.

4. In the Interactive mode, we can type the command in the 
window and the Python interpreter will execute the command 
and give us the result immediately whereas Script mode is used 
to	write	and	save	the	programs	in	the	form	of	a	file.

Chapter 11
A. Fill in the blanks:
	 1.	Artificial	Intelligence	 2.	Intelligence
 3. Learning 4. Bias 5. Algorithms
B. True or False:
 1. False 2. True 3. False 
 4. False 5. True
C. Application based questions:

1. The decision based on human intelligence can be biased 
whereas the decision making capability of AI will be free from 
any bias.

2.	The	world	of	Artificial	Intelligent	machines	is	so	wide.	Some	AI	
based machines are Chatbots, Voice Assistants etc.

D. Tick mark:
 1. Problem Solving
 2. Nature
 3. All of these
 4. Programming with AI
 5. Both (b) and (c)
E. Answer the following:

1.	Artificial	Intelligent	machines	are	able	to	carry	out	certain	tasks	
that require human beings to use their intelligence.

2.	The	main	objective	of	Artificial	 intelligent	machines	 is	 to	aid	
human capabilities and help us make advanced decisions.

3.	After	 the	 existence	 of	 artificial	 intelligence	 technology,	
programming can be differentiated in two ways:
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 (a) Programming with AI
 (b) Programming without AI
 The main difference between these two are as follows:

S.No. Programming With AI Programming Without AI

1. A computer program 
with AI can answer 
generic questions it is 
meant to solve.

A computer program 
without AI can answer
the	specific	questions	it
is meant to solve.

2. These programs 
can absorb new 
modifications	 by	
putting highly 
independent pieces of
information together.

Modification	 in	 the	
program leads to change 
in the Programming 
structure.

4.	The	two	merits	of	Artificial	Intelligence	are:
(a)	Artificial	 Intelligent	Machines	are	able	 to	perform	the	 job	

continuously without getting bored or distracted.
(b) AI machines have a great power to detect smart card based 

system transactions fraud within a millisecond.
In addition to merits, some demerits of AI are :
(a)	Artificial	Intelligent	machines	are	complex	in	nature.
(b) AI machines cannot be improved with experience.

5.	The	 difference	 between	 Human	 Intelligence	 and	 Artificial	
Intelligence are:
(a)	Nature:	 Human	 Intelligence	 is	 natural	 whereas	 artificial	

intelligence	is	artificial	in	nature.
(b) Decision-making: Human decision making can be biased 

whereas the decision making capability of AI will be free 
from any bias.

Worksheet 2
A. Fill in the blanks:
 1. Workbook 2. .WAV 3. F8
 4. Playhead 5. Web Browsers
B. True or False:
 1. True 2. True 3. True 
 4. True 5. False
C. Tick mark:
 1. Animations 2. Merge & Center 3. Pencil
 4. Button 5. F4
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D. Answer in one word or a sentence:
1. Esc key
2. 1048576 rows and 16,384 columns.
3. Ctrl +Y
4. MS Excel
5. <HR>

E. Answer the following:
1. Animation refers to the process of moving objects like text, 

graphics, charts in a slide. It is helpful to highlight important 
points while delivering a presentation.

2. A Workbook is like a notebook which consists of a number of 
pages whereas worksheets in a Workbook are like pages of a 
notebook.

3.	Autofill	 is	 the	 easiest	 method	 to	 fill	 data	 in	 the	 cells	
automatically. We can use it in a Worksheet by follow the given 
steps:
(a) Type any week day in a cell and position the Pointer at the 

lower right corner of the cell.
(b) The mouse pointer changes into a thin black cross. Hold 

down	the	left	mouse	button	and	drag	the	fill	handle	up	to	
the	cells	that	we	want	to	be	filled	in.

(c) Release the button.
4.	The	main	objective	of	Artificial	 intelligent	machines	 is	 to	aid	

human capabilities and help us make advanced decisions.
5. Tags: Tags are the special keywords enclosed between the 
angle	brackets.	They	contain	elements	which	define	how	the	
information on a web page is displayed. 

 Attribute: An Attribute is the property that provides additional 
information about an HTML element. It enhances the 
functionality of a tag.

F. Match the following:

S.No. Column A Column B

1. Formula Equal to Sign

2. Insert a keyframe Ctrl+F9

3. To minimize the worksheet F6

4. Redo action Ctrl+Y

G. Write the function of the following tools:
 1. Stop 2. Record 3. Pen 4. Video


